Back to overview
Degraded

There are occasional slow page loads

Jul 18 at 07:03am HDT
Affected services
Continue Hub

Resolved
Jul 18 at 07:45am HDT

We have released a fix for the issue and load times have been restored. Given the number of degradations in the last few days we are taking significant steps to improve our reliability.

Created
Jul 18 at 07:03am HDT

Some users are seeing 504s or slow page loads